Home > An Error > Archives Path '/usr/local/rvm/archives' Not Writable, Aborting.

Archives Path '/usr/local/rvm/archives' Not Writable, Aborting.

Contents

Finally, this answer on stackoverflow provided a fix that was easy to try, and I knew it wouldn't break anything-it suggested updating rvm, which has the new certificates, and pointed out Derogatory term for a nobleman How to deal with being asked to smile more? Are assignments in the condition part of conditionals a bad practice? more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed

Halting the installation. So basically I had two problems, the tutorials that i followed didn't say that i should run source /home/my-desktop-username/.rvm/scripts/rvm and didn't say that I should not run rvm as root, s.m Derogatory term for a nobleman Why don't miners get boiled to death at 4 km deep? Is there something wrong with my curl? check this link right here now

Archives Path '/usr/local/rvm/archives' Not Writable, Aborting.

Note, rvm uninstall ruby-2.1.4 failed, same problem with __rvm_rm_rf, so I have to implode RVM to remove ruby and try the install again: (localhost) ~ rvm uninstall ruby-2.1.4 ruby-2.1.4 - #removing In the US, are illegal immigrants more likely to commit crimes? ruby-2.0.0-p451 - #downloading ruby-2.0.0-p451, this may take a while depending on your connection... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed I think I may have mistakenly installed rvm as root at one point... –MarkL Oct 3 '11 at 18:41 seems right, is there any more info in /Users/mark/.rvm/log/ruby-1.9.2-p290/*.log as

Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox. Upgrade of RVM in /Users/rmichael/.rvm/ is complete. # Richard Michael, # # Thank you for using RVM! # We sincerely hope that RVM helps to make your life easier and more I have rvm but for some reason I can't download the version of ruby that I need. Could Not Download Rvm-installer No binary rubies available for: ubuntu/15.10/x86_64/ruby-2.2.1p85.

Halting the installation. There Was An Error(23) After rvm cleanup all, I can compile if I add --trace to workaround whatever the problem is with extraction, e.g. Search for: Recent Posts Bartle Test too close to home happy new year! chown did though. –wejrowski Apr 4 '12 at 18:48 If you're going to chown the directory to a single user, just install rvm in single-user mode. –GregB Jan 12

If the default
bundle file isn't adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA Uninstall Rvm Feb 24 '12 at 23:36 @s.m. Then I copy the requirements and close the session, open a root session and install the requirements using sudo Then I close the session and open a normal user session and Is the ability to finish a wizard early a good idea?

There Was An Error(23)

Installing Ruby from source to: /Users/rmichael/.rvm/rubies/ruby-2.1.4, this may take a while depending on your cpu(s)... is still broken. Archives Path '/usr/local/rvm/archives' Not Writable, Aborting. Why is the size of my email so much bigger than the size of its attached files? Rvm Curl Returned Status '23'. I'm trying:Code: Select allsudo gem install bundler
andCode: Select allrvm install ruby-2.1.2Result of first one:Code: Select allERROR: Could not find a valid gem 'bundler' (>= 0) in any repository
ERROR:

make was using the libiconv.2.dylib in /usr/local/lib/, but we want to use the one in /usr/lib. Yay! ruby-1.9.3 - #fetching ruby-1.9.3 - #extracting ruby-1.9.3- to /usr/share/ruby-rvm/src/ruby-1.9.3 ERROR: Error running 'bunzip2 < '/usr/share/ruby-rvm/archives/ruby-1.9.3-.tar.bz2' | tar xf - -C /usr/share/ruby-rvm/tmp/rvm_src_4428', please read /usr/share/ruby-rvm/log/ruby-1.9.3/extract.log ERROR: There has been an error while Halting the installation. Rvm Curl: (23) Failed Writing Body

Here is the log file from --trace, the parts between curl and the configure start. Already have an account? ruby-2.1.4 - #downloading ruby-2.1.4, this may take a while depending on your connection... Simply run sudo adduser rvm. –Bryan Oct 25 '11 at 17:42 I tried running sudo adduser rvm and didn't seem to work..

Sign in to comment Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc. Install Rvm Ubuntu A tail on ~/.rvm/log/ruby-1.9.3-p125/extract.log said: bunzip2: (stdin) is not a bzip2 file. There has been an error fetching the ruby interpreter.

mpapis Michal Papis GPG key ID: E206C29FBF04FF17 Learn about signing commits 7d66305 Ruby enVironment Manager member mpapis commented Nov 11, 2014 try again, not sure it is it but

Installing Ruby from source to: /usr/local/rvm/rubies/ruby-2.1.1, this may take a while depending on your cpu(s)... Top Display posts from previous: All posts1 day7 days2 weeks1 month3 months6 months1 year Sort by AuthorPost timeSubject AscendingDescending Post Reply Print view 2 posts • Page 1 of 1 Return asked 5 years ago viewed 2900 times active 2 years ago Linked 1 Installing Ruby 1.9.2 via rvm. Rvm Install Ruby Group memberships are processed at login, so in order to write to /usr/local/rvm, you must log out and then log in so that the OS recognizes that you're in the rvm

Thanks so much for all the help! Seguin <[email protected]>, Michal Papis [https://rvm.io/] richardkmichael commented Nov 10, 2014 Now trying this after rvm get head. How do we play with irregular attendance? Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 158 Star 3,466 Fork 811 rvm/rvm Code Issues 191 Pull requests 4 Projects

nokogiri) share|improve this answer edited Apr 3 '14 at 20:09 answered Apr 3 '14 at 19:48 Andrew 41436 add a comment| Your Answer draft saved draft discarded Sign up or Skipping update of certificates in '/opt/local/etc/openssl/cert.pem', to force update run: rvm osx-ssl-certs update /opt/local/etc/openssl/cert.pem RVM autolibs is now configured with mode '2' => 'Allow RVM to use package manager if found, Installing Ruby from source to: /usr/local/rvm/rubies/ruby-1.9.3-p484, this may take a while depending on your cpu(s)... Join them; it only takes a minute: Sign up Installing RVM: getting error “There was an error(23).” up vote 12 down vote favorite 4 I am trying to install ruby version

Without --trace it fails (note I had to rvm implode because rvm uninstall ... Encode the alphabet cipher Why were Navajo code talkers used during WW2? Lengthwise or widthwise. Continuing with compilation.

Installing Ruby from source to: /Users/rmichael/.rvm/rubies/ruby-2.1.4, this may take a while depending on your cpu(s)... YouTube Videos: Google returns non-existant meta description and different keywords medoo framework in WP plugin Why do (some) aircrafts shake at low speeds with flaps, slats extended? RVM PATH line not found for Bash, rerun this command with '--auto-dotfiles' flag to fix it. But if I remove '--no-same-owner' the promlem dissapeared.

[email protected]:/tmp$ rvm install ruby-1.9.3-p484 Searching for binary rubies, this might take some time. No binary rubies available for: ubuntu/14.04/x86_64/ruby-1.9.3-p484. Partial sum of the harmonic series between two consecutive fibonacci numbers Why were Navajo code talkers used during WW2? I install under no-root account and the problem disapeared.

How do you enforce handwriting standards for homework assignments as a TA? What solved for you @Demas? –YogiZoli Mar 13 '12 at 17:55 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign Please read 'rvm help mount' to get more informatio Print some JSON Number sets symbols in LaTeX How do really talented people in academia think about people who are less capable than them?

Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the